Início > Fore Front TMG 2010 > Erro no acesso a sites internos via Forefront TMG

Erro no acesso a sites internos via Forefront TMG

Saudações,

O mundo Forefront TMG essa semana está deverás movimentado! Muitos assuntos correram pela comunidade técnica e nos blog´s dos grandes nomes da matéria. Sobre este assunto irei falar no próximo post, pois ainda estou lendo as informações e analisando uma a uma.

Essa semana fui chamado a verificar o caso de um site de intranet em um de nossos clientes. O site está publicado internamente e externamente tb. Para os acessos externos uma página de autenticação é chamada para uso do smart card e, nos acessos internos, o username já valida o acesso.

O fato é que, de dentro da rede interna, esse acesso não ocorria. A página em questão fica hospedada em um webserver na Europa e o Forefront TMG trabalha como proxy no padrão single network adapter. Para toda requisição externa, ou para sites hospedados fora do Brasil, um network chaining direciona para um firewall de borda.

Ao testar o acesso vi que o TMG tratava a requisição como interna, ou seja, roteava para a própria rede. Cheguei a excluir o IP do site da range interna e o erro persistia. Como último teste, fiz o acesso pelo próprio browser do TMG apontando para o IP do firewall de borda e mesmo assim o erro persistia.

Dessa forma concluí que o problema não estava no TMG. Ao verificar com os responsáveis pelo firewall foi constatado a falta de uma rota estática entre este firewall e o endereço do web server.

Após aplicação desta rota o acesso ocorreu normalmente.

Conclusão – em ambientes em que se usa o Single Network Adapter, tenha sempre em mente testar o acesso diretamente pelo dispositivo que dá o acesso a TMG.

Abraços

Uilson

Categorias:Fore Front TMG 2010
  1. 27 de fevereiro de 2012 às 8:18

    Estimados,
    Estou com um problema semelhante envolvendo a autenticação de dois factores no Forefront TMG.
    Tenho um site e a autenticação é feita através de User/ Password e também através de Smart Card.
    Quando autentico na intranet a pagina solicita os dois factores de autenticação (senha/password e o cartão). O estranho acontece quando autentico na internet onde não me é reconhecida a autenticação através do Smart Card, sendo solicitada apenas senha/password.

    Nesse caso a solução passaria também por fazer um rateamento estático entre o firewall e o endereço da Web Service.

    • 29 de fevereiro de 2012 às 12:00

      Celestino, conforme nosso contato, vou tem que configurar o seu listener e habilitar a autenticação via RSA…

  1. No trackbacks yet.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: